RPIEasy
2019. január 02. írta: eNeS

RPIEasy

RPIEasy

rpi_devs.png

A bejegyzés trackback címe:

https://bitekmindenhol.blog.hu/api/trackback/id/tr2714529666

Kommentek:

A hozzászólások a vonatkozó jogszabályok  értelmében felhasználói tartalomnak minősülnek, értük a szolgáltatás technikai  üzemeltetője semmilyen felelősséget nem vállal, azokat nem ellenőrzi. Kifogás esetén forduljon a blog szerkesztőjéhez. Részletek a  Felhasználási feltételekben és az adatvédelmi tájékoztatóban.

ha5gyp 2019.01.03. 14:25:49

Szia !

Elöször is gratula, szép munka !!
Feltettem az RPIEasy-t egy régi Raspberry 1-re. Teljesen jól szuperál, de van egy gondom vele:
Amikor kapcsoló eszközt (Input - Switch Device/Generic GPIO) definiálok, az nem akar működni... Akármit állítók a Pinout&Port-nál, akármelyik GPIO-ra rakom, nem érzékeli a változást... A GPIO portal biztosan nincs baj, mert amikor egy DHT szerzort beállítok ugyanarra, az rendben működik, de ha simán Bash-ban olvasom a portot, ott is rendben van. A másik érdekesség, hogy amikor újraindítom a raspberryt, eltűnnek a kapcsoló beállításai ! Mintha nem is adtam volna hozzá kapcsoló eszközt. Minden más rendben működik (ezeket próbáltam: DHT11/22, BMP280, systeminfo), de a switch nem akaródzik....
Van valami tipped ?

+1 javaslat:
A telepítési leírásba írd bele, hogy indítás előtt a Jsonpickle-t is telepíteni kell a "sudo pip3 install jsonpickle" paranccsal, különben nem fog elindulni az RPIEasy...

ha5gyp 2019.01.03. 23:00:32

@ha5gyp: Oké, mielőtt valaki szintén úgy jár, mint én, és feleslegesen kongatja a vészharangot, az alábbi 3 parancsot futtassa:
sudo rpi-update
sudo apt-get update
sudo apt-get upgrade

Utána egy reboot, és varázsütésre nagyon sok probléma megoldódik....

eNeS 2019.01.03. 23:24:39

@ha5gyp: ez jó tipp, felvesszük a listára! :)

tomih 2019.04.23. 13:43:58

Szia!

RPi 1-re telepíteném, de mielőtt neki kezdek, megkérdezném működik wifi interfész nélkül is? (a RPi1-be még nem volt.)
A "primary network device"-nál eth0 is megadható?

eNeS 2019.04.23. 16:05:07

@tomih: igen, használható, USB LAN kártyával is használom jelenleg is.

tomih 2019.04.24. 12:48:57

@eNeS: Köszi, kipróbálom.

tomih 2019.05.04. 16:11:03

Szuper, sikerült telepíteni!

ha5gyp 2019.05.11. 20:12:28

Feltettem egy régi Raspberry 1-re, a legújabb 2019-04-08-raspbian-stretch-lite verzióval, hiba nélkül. Elindítom, nincs hibaüzenet, de így néz ki a webes felület: i.imgur.com/KGDBOVn.png
Ráadásul folyamatosan tölt valamit.
Nincs semmi hibaüzenet, pedig a debug level-t már develop szintre tettem...
Mi lehet a gond ? Olyan, mintha vmit nem telepítettem volna fel...

eNeS 2019.05.11. 20:45:31

@ha5gyp: a webes felületen nem fogsz látni semmit, ha egy mélyebben levő hibában akadt el a beépített webkiszolgáló sajnos.. ha sudo ./RPIEasy.py -vel elindítod a linux konzolban mit látsz?

ha5gyp 2019.05.11. 20:52:49

@eNeS: i.imgur.com/YvNe6hO.png
És így tovább, ugyanezeket ismétli

ha5gyp 2019.05.11. 20:54:15

@eNeS: A linux érintetlen, csak feltelepítettem, frissítettem, majd feltettem az RPIEasy-t

eNeS 2019.05.11. 21:48:38

@ha5gyp: ez nem túl sok, melyik oldalra kattintasz, amikor megáll a webes felület, és csak teker? gondolom nem a főoldalon, mert akkor nem tudnál debug levelt állítani.. A data/ mappád tartalmát fel tudod tölteni tömörítve valahová? Azzal elvileg tudom reprodukálni a hibát én is.

ha5gyp 2019.05.11. 23:15:31

@eNeS: Sajnos nem hiszem, hogy sokra mész a data mappával... data.hu/get/11821168/data.rar
Igazából mindegy hová klikkelek a webes felületen, mindenhol teker.... Debug levelt úgy tudtam állítani, hogy direktbe beírtam az /advanced címet. itt is tekert, de engedte beírni és elmenteni.

eNeS 2019.05.12. 00:13:51

@ha5gyp: Telepítés után azért felraktad a függőségeket? "sudo apt install python3-pip screen alsa-utils zip unzip git
sudo pip3 install jsonpickle" Átállítottam a Zerom típusát PI 1 Model B-re egy teszt erejéig, átmásolva a data mappád tartalmát, de nem történt semmi hiba. Lehet böngésző vagy LAN kapcsolat hiba is... a "tekerés" a végén attól lehet, hogy nem kapta meg az RPIEasy irányából az oldal vége jelet. Ha ténylegesen elakadt volna a webkiszolgáló akkor nem tudnál többet kattintani sehová és nem hozta volna létre az advsettings.json fájlt sem.

ha5gyp 2019.05.12. 13:04:53

@eNeS: Igazad volt, de ez nagyon érdekes ! Újra telepítettem a Rasbian-t, majd az RPi-t, de ugyanúgy nem ment Firefox alatt. Aztán megnéztem másik böngészőbe (Edge) és gond nélkül bejött ! Firefox uninstall (minden kiegészítő és extra mappa törlése), majd Firefox reinsall, de ott továbra sem jön be ! Próbáltam azt is, hogy alapállapotba állítom a Firefoxot, de akkor sem muxik. Nem tudom mi lehet a gond. Tűzfal/viruskergető biztosan nem, mert akkor Edge alatt sem menne.

ha5gyp 2019.05.12. 14:15:02

@eNeS: Oké, valami helyi gond lesz nálam, ezzel a géppel, mert másik gépről megnyitva Firefox alatt is rendben megy ! Magamba szállok és megpróbálom kideríteni mi a gond... köszi a segítséget !

ha5gyp 2019.05.12. 14:17:31

@ha5gyp: Módosítok: Windows-os Firefox alatt nem muxik, de Linuxos (Ubuntu) alatt rendben muxik.

eNeS 2019.05.12. 16:37:31

@ha5gyp: ezt jó tudni, én is Firefoxot használok, de csak Ubuntuval, így nem is tűnt volna fel a dolog. :)